ClickCease

CCNA

A Data Analyst processes and visualizes data using tools like R, Tableau, and Power BI. This CCNA provides key functions, techniques, and tips for effective data analysis and visualization.

1. R for Data Analysis

Installing & Loading Libraries

install.packages(c("tidyverse", "dplyr", "ggplot2", "readr", "data.table"))

library(tidyverse) 

library(dplyr)

library(ggplot2)

library(readr)

library(data.table)
Loading & Exploring Data

df <- read.csv("data.csv")  # Load CSV file

str(df)  # Check structure

summary(df)  # Summary statistics

head(df)  # First 6 rows
Data Cleaning
df <- df %>% drop_na()  # Remove missing values

df <- df %>% rename(new_name = old_name)  # Rename column

df$category <- as.factor(df$category)  # Convert column type

df <- df %>% mutate(new_column = column1 + column2)  # Create new column
Filtering & Sorting Data  

df_filtered <- df %>% filter(Salary > 50000)  # Filter rows

df_sorted <- df %>% arrange(desc(Salary))  # Sort descending
Aggregating Data

df_summary <- df %>%

group_by(Department) %>%

summarise(Avg_Salary = mean(Salary, na.rm=TRUE))

2. Data Visualization in R (ggplot2)

Bar Chart

ggplot(df, aes(x=Department, y=Salary)) +

geom_bar(stat="identity", fill="blue")
📌 Histogram

ggplot(df, aes(x=Salary)) +

geom_histogram(bins=30, fill="green", color="black")
Scatter Plot with Trend Line

ggplot(df, aes(x=Experience, y=Salary)) +

geom_point() +

geom_smooth(method="lm", col="red")

3. Tableau for Data Visualization

📌 Steps to Create Dashboards in Tableau
  1. Connect Data: Import CSV, Excel, SQL Server, or Cloud data
  2. Prepare Data: Use “Data Interpreter” to clean messy data
  3. Create Charts:
    • Drag & drop Dimensions (Categories) and Measures (Numerical)
    • Choose visualization types (Bar Chart, Pie Chart, Heatmap, etc.)
  4. Build a Dashboard:
    • Combine multiple charts
    • Use Filters, Parameters, and Actions for interactivity
  5. Publish & Share:
    • Save to Tableau Public or Server
    • Export as PDF, Image, or Web Report
Common Visuals in Tableau
Chart Type When to Use
Bar Chart Compare categories (e.g., Sales by Region)
Line Chart Show trends over time (e.g., Monthly Revenue)
Heatmap Identify patterns (e.g., Customer Engagement by Hour)
Pie Chart Show proportions (e.g., Market Share)
TreeMap Display hierarchical data (e.g., Sales by Product)
Calculated Field in Tableau tableau

IF [Sales] > 5000 THEN "High" ELSE "Low" END

4. Power BI for Business Intelligence

Steps to Build Reports in Power BI
  1. Load Data: Connect to Excel, SQL, Cloud, APIs
  2. Transform Data: Use Power Query to clean & reshape
  3. Build Visualizations:
    • Drag fields into Reports View
    • Select chart types & apply filters
  4. Create Dashboards:
    • Combine multiple reports
    • Add Slicers, Filters, and Drill-Throughs
  5. Publish Reports:
    • Share via Power BI Service
    • Embed in websites or applications
DAX (Data Analysis Expressions) for Calculated Fields DAX

Total_Sales = SUM(Sales[Revenue])

Avg_Salary = AVERAGE(Employees[Salary])

Sales_Percentage = DIVIDE([Total_Sales], SUM(Sales[Total]), 0)
Common Power BI Charts
Chart Type Use Case
Bar Chart Compare categories (e.g., Sales by Region)
Line Chart Show trends over time
Pie Chart Display proportions
Map Visualization Show geographical data
KPI Card Display key metrics (e.g., Total Sales)

5. Key Differences: Tableau vs Power BI

Feature Tableau Power BI
Ease of Use User-friendly drag & drop Requires Power Query knowledge
Data Sources Supports multiple sources Best for Microsoft ecosystem
Performance Fast for large datasets Slower for complex models
Visualization High customization Limited compared to Tableau
Cost Expensive Affordable (Free Desktop Version)

6. Data Analyst Best Practices

  • Data Cleaning: Handle missing values, remove duplicates.
  • Data Exploration: Identify patterns & trends before visualization.
  • Use Filters & Slicers: Allow users to interact with reports.
  • Automate Reports: Schedule updates in Power BI & Tableau.
  • Optimize Performance: Reduce data load & improve dashboard speed

7. Learning Resources

R for Data Science – Book Tableau Public Guide – Tutorial Power BI TrainingMicrosoft Docs Kaggle Datasets – Explore

8. Networking Basics

Key Networking Components
  • Router: Connects different networks (e.g., LAN to WAN)
  • Switch: Connects devices within a LAN
  • Firewall: Controls incoming/outgoing traffic based on security rules
  • Hub: Broadcasts traffic to all devices
  • Access Point (AP): Wireless device that connects clients to a wired network
Network Topologies
Type Description
Bus Single backbone, all devices connect
Star Devices connect to a central switch
Ring Devices connected in a loop
Mesh Devices interconnected (full or partial)
Hybrid Combination of two or more topologies
IP Addressing (IPv4 & IPv6)
  • IPv4: 32-bit, e.g., 192.168.1.1
  • IPv6: 128-bit, e.g., 2001:db8::ff00:42:8329
IPv4 Classes
Class Range Default Subnet Mask
A 1.0.0.0 – 126.255.255.255 255.0.0.0
B 128.0.0.0 – 191.255.255.255 255.255.0.0
C 192.0.0.0 – 223.255.255.255 255.255.255.0
D (Multicast) 224.0.0.0 – 239.255.255.255 N/A
E (Experimental) 240.0.0.0 – 255.255.255.255 N/A
Subnetting Basics
  • Subnet Mask: Defines the network & host portions
  • CIDR Notation: /24 means 255.255.255.0
  • Formula:
    • Hosts per subnet: 2^(32 – subnet bits) – 2
    • Subnets available: 2^borrowed bits
Example:
  • IP Address: 192.168.1.10/24
  • Subnet Mask: 255.255.255.0
  • Network ID: 192.168.1.0
  • Broadcast Address: 192.168.1.255
  • Hosts per subnet: 254

9. Routing & Switching

Routing Basics
  • Static Routing: Manually configured routes
  • Dynamic Routing: Protocols like RIP, OSPF, EIGRP, BGP
Common Routing Protocols
Protocol Type Metric Usage
RIP Distance Vector Hop Count Small networks
OSPF Link State Cost Large networks
EIGRP Hybrid Bandwidth & Delay Cisco proprietary
BGP Path Vector AS Path Internet routing
Switching Concepts
  • MAC Address Table: Stores device MAC addresses
  • VLAN (Virtual LAN): Segments network traffic logically
  • Trunking (802.1Q): Allows multiple VLANs on one link
  • STP (Spanning Tree Protocol): Prevents loops
VLAN Configuration (CLI)

bash

Switch(config)# vlan 10

Switch(config-vlan)# name Sales

Switch(config-vlan)# exit

Switch(config)# interface fastEthernet 0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 10
Trunk Port Configuration

bash

Switch(config)# interface fastEthernet 0/2

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk allowed vlan 10,20

10. Network Security

Security Concepts
  • AAA (Authentication, Authorization, Accounting)
  • ACL (Access Control Lists): Filters network traffic
  • Firewall: Blocks/Allows traffic based on rules
  • VPN (Virtual Private Network): Encrypts remote connections
Standard ACL Configuration

bash

Router(config)# access-list 10 permit 192.168.1.0 0.0.0.255

Router(config)# interface fastEthernet 0/0

Router(config-if)# ip access-group 10 in
Extended ACL Configuration bash

Router(config)# access-list 100 permit tcp any host 192.168.1.1 eq 80

Router(config)# interface fastEthernet 0/0

Router(config-if)# ip access-group 100 in

11. Network Automation & Troubleshooting

Automation with Cisco CLI Show Commands

bash

show ip interface brief  # Check interfaces

show running-config  # View running config

show vlan brief  # VLAN details
Debugging

bash

debug ip route  # Monitor routing updates

debug arp  # Check ARP activity
Saving Configuration

bash

copy running-config startup-config
Troubleshooting Commands
Command Purpose
ping <IP> Check connectivity
traceroute <IP> Trace packet path
show ip route Display routing table
show mac address-table View MAC table
show interfaces Check interface status

12. CCNA Exam Tips & Study Resources

Study Tips
  •  Understand subnetting and practice IP calculations.
  • Memorize key Cisco CLI commands..
  • Practice VLANs, ACLs, and routing configurations.
  •  Use Packet Tracer or GNS3 for hands-on labs.
  •  Watch Cisco learning videos and read official study guides
Recommended Resources
  • Cisco CCNA 200-301 Official Cert Guide
  • Cisco Packet Tracer for simulations
  • NetworkChuck (YouTube)
  • Wendell Odom’s CCNA Study Guide
  • Boson CCNA Practice Tests VLAN Configuration

bash

Switch(config)# vlan 10

Switch(config-vlan)# name Sales

Switch(config-vlan)# exit

Switch(config)# interface fastEthernet 0/1

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 10
Trunking Configuration

bash

Switch(config)# interface fastEthernet 0/2

Switch(config-if)# switchport mode trunk

Switch(config-if)# switchport trunk allowed vlan 10,20
Static Routing

bash

Router(config)# ip route 192.168.2.0 255.255.255.0 192.168.1.
1 🔄 Dynamic Routing (OSPF) Router(config)# router ospf 1 Router(config-router)# network 192.168.1.0 0.0.0.255 area 0

13. Troubleshooting Commands

Command Purpose
ping <IP> Check connectivity
traceroute <IP> Trace packet path
show ip route Display routing table
show mac address-table View MAC table
show interfaces Check interface status
debug ip ospf events OSPF troubleshooting

14. Network Automation

Show Commands

show ip interface brief  # View interface status

show running-config  # View current configuration

show vlan brief  # View VLAN configuration
   
Facebook
X
LinkedIn
Pinterest
WhatsApp